Skip to content
0:00 / 0:00

#flutter#dart#opensource

FLOSS Weekly 439: Flutter

Untitled Linux Show

8.2K subscribers • 1 video on Hallway

YouTube
  • Recommended by 2 people: 2 in engineering communities.
  • Presented by Adam Barth, co-founder of Flutter
  • May be out of date. Uploaded 9 years ago, in an area where tools change fast.

Beginner. No background in the topic needed.

871 views9 years ago2 recommendations

Mobile developmentHistory and cultureFlutter and React NativeThe tech industryHistory of computing

Adam Barth discusses the origins of Flutter, its design choices, and how features like stateful hot reload were developed.

Flutter is a new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android. Adam is a co-founder of the Flutter project. Prior to starting Flutter, he was a top contributor to the open-source WebKit and Blink web rendering engines. He co-invented HTTP Strict Transport Security and wrote several Internet standards, including RFC 6265 (HTTP Cookies), RFC 6454 (The Web Origin Concept), and RFC 6797 (HTTP Strict Transport Security) at IETF and Content Security Policy 1.0 at W3C. Download or subscribe to this show at twit.tv/shows/floss-weekly Here's what's coming up for FLOSS in the future. Think your open source project should be on FLOSS Weekly? Email Randal at merlyn@stonehenge.com

Why it's here

2 people recommend this

What people say. Recommended for its historical context on why Flutter chose Dart and how stateful hot reload was conceived.

Moments people linked to

u/Purple_Pizzazzin r/FlutterDev • Recommends

FLOSS Weekly: Flutter

u/sebe42in r/FlutterDev • Recommends

On “It seems like flutter is keeping Dart alive. Would it be possible for Flutter to use ex Kotlin, Swift or any other popular language instead?”

Dart predates TypeScript and was started at the same time as Kotlin. When the Sky project, now called Flutter, gave up on using JavaScript they looked at several language before giving Dart a go. Here is a floss weekly episode with one of the co-founders, talks about flutter's hotreload, an idea that came from the Dart team. [video If swift was opensource back then they may have gone with it and if they started today they may have gone with kotlin native. Flutter's hotreload feature, something that they didn't know they wanted, was created after they decided to give Dart a go. While the Dart team had missed the boat on getting the Dart VM into chrome, they still had their internal cu…
4View on Reddit

u/sebe42in r/FlutterDev • Recommends

On “Dart is the biggest failure of flutter.”

…giving Dart a go . Stateful Hot reload is one of the top features of flutter, an idea that original came from the dart team, based on the way dart language is structured and the way the runtime works, they built a prototype. Here is a link to FLOSS Weekly episode from 2017 where flutter guy said "wow this is amazing" in regards to hot reload. [video Tidbit, the original Dart guys, Lars and Kasper have left google and have been working on https://www.toitware.com/…